🍏 OS X - Essentials
This note lists essential Mac OS X stuff. Image editing related tools and extensions are listed in image tool notes.
Keybindings
Use spotlight to open everything. Have a file on desktop under all the windows or "somewhere" on your computer that you want to open? Open spotlight and type the name and press enter to open it.
Enable mouse zoom functionality. Really important to increase the dramatic effect when showing a bug to fellow developers.
System Preferences > Accessibility > Zoom
Use scroll gesture with modifier key to zoom: Control
Enable full keyboard access to controls. I hate touching the mouse.
System Preferences > Keyboard > Shortcuts...
Full Keyboard Access: All Controls
Now you can:
- Jump between popover buttons with Tab and Shift + Tab
- Select the focused action with space.
- Enter still selects the primary option, highlighted blue by default.
- Esc still selects the espace option, usually cancel.
- Doesn't work on all popups though :(
Browsing with only keyboard. I just really hate touching the mouse.
- Chrome without plugins:
- Cmd+F, type and press Enter until your link is selected then Esc and Enter.
- Cmd+1: Switch to tab 1 etc.
- Cmd+LEFT: Back
- Cmd+RIGHT: Forward
- Cmd+L: go to address bar
- Bookmark Search: Search from bookmarks when typing to address bar.
Other important OS X keybindings:
- Cmd+W: Close selected tab or window.
- Cmd+Q: Close selected app.
- Cmd+Shift+4: Take snapshot from the following selection and save to desktop.
- Alt+D: CUSTOM REBIND, minimize everything and show desktop, "same" as Windows
- Alt+Q: CUSTOM REBIND, open Spotlight, "same" as Windows
Applications
Use Homebrew. Clean and efficient way to manage command line applications. Everything is stored in /usr/local/
Add Cask to Homebrew. It contains installable desktop application binaries.
brew tap caskroom/cask
brew cask install hyperswitch iterm2 sourcetree cyberduck keka
HyperSwitch: Change Cmd+Tab behavior similar to Windows where you switch between windows, not applications.
iTerm 2: The best terminal application after you fix few keybindings.
Keka: The best zip/rar/7zip tool.
SourceTree: The best Git/Mercurial client, if you ever need to go visual for some reason.
Cyberduck: The best FTP/AWS/etc client.
Tabula: Extract table data from PDFs.
Disc Doctor: Simple application to free space fast.
Quicksilver: Run scripts on keybindings.
Commands
open . # start finder here
open config.txt # open default text editor
open 1.jpg 2.jpg 3.png # files in default image viewer
ls ~ | pbcopy # copy return to clipboard
pbpaste >> tasklist.txt # paste clipboard to a file
mdfind -onlyin ~/Dropbox latex # search using Spotlight index
# Cmd + Shift + 4 will take screenshots and place them on desktop
screencapture --help
screencapture -C hello.png # capture screen and save to hello.png
screencapture -C -t jpg hello.jpg # save as jpg
screencapture -W -t jpg hello.jpg # capture window and save to file
screencapture -W # select window and screenshot to clipboard
# launchctl OS X init script system.
# you can find all available scripts in:
ls ~/Library/LaunchAgents
ls /Library/LaunchAgents
ls /Library/LaunchDaemons
ls /System/Library/LaunchAgents
ls /System/Library/LaunchDaemons
# list currently loaded daemons
launchctl list
# start
launchctl load -w /System/Library/LaunchDaemons/org.apache.httpd.plist
# stop
sudo launchctl unload /System/Library/LaunchDaemons/org.apache.httpd.plist
# stop and remove from init
sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist
Scripts
- Install Quicksilver.
- Create
FinderNewWindow.scpt
somewhere on your machine. - Paste in the next block
- Add new Trigger.
- Drag script to the the top box.
- Select Run on the second box.
# Open new Finder window, Alt+E
on run
tell application "Finder"
activate
end tell
tell application "System Events"
tell process "Finder"
tell menu bar 1
tell menu "File"
click menu item "New Finder Window"
end tell
end tell
end tell
end tell
end run